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Learning Goals
In this tutorial segment, we will cover:

•	 Physics and Solver Settings in Ansys Fluent Solver
	» Material Properties
	» Boundary Conditions

•	 Solver Settings
•	 Simulation Setup

Open Ansys Fluent Software in Solution Mode
To read the CFD mesh: 

File→Read→Mesh→Choose the .msh.h5  file generated in Ansys Fluent Meshing.

Domain→Mesh→ Display can be used to visualize the geometry

Note: Visualizing the geometry and the coordinates is necessary for the scale check in the next step 
and to set up the gravitational direction properly. This is to ensure that the geometric dimension and 
unit when the mesh is imported are correct. 

Check the scale of the geometry:

Domain→Mesh→Scale

 

Ansys Software Used

This tutorial segment uses Ansys Fluent®, the fluid simulation software.
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You may initially observe that the distance along the x-direction (from head to foot) is approximately 
240 meters, which is incorrect. The length of the trachea is typically around 100 millimeters. This 
discrepancy indicates that the unit used by the Ansys Fluent Solver to import this geometry is meters 
instead of the correct unit, which should be millimeters. Therefore, it is necessary to properly scale the 
geometry: 

Domain→Mesh→Scale→Set “Mesh was created in” as “mm”→Click “Scale” (see the setup as shown 
in the snapshot below).

Set the gravity direction:

Task page→Check “Gravity”→Enter “9.81” in x-direction of “Gravitational Acceleration”, the unit 
should be in m/s2

Steady-State Airflow Simulations
We will first run a steady-state airflow field simulation. We will follow the outline view menu and work 
from the top to the bottom to set up the laminar steady-state simulation for airflow first. 

Models→Viscous→Laminar (since the inhalation flow rate is 6 L/min and the Reynolds number is 
around 500)

Materials→Fluid→Make sure the fluid material is “Air”.

Boundary conditions→Inlet:141→Change the type to Velocity Inlet→Double click inlet: 
141→Momentum→Velocity Magnitude→type “0.5” which is 0.5 m/s responding to 6 L/min
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Boundary conditions→Outlet→change all outlet surfaces named “o**” type to “pressure outlet”→ Set 
“Gauge Pressure” to 0 for all outlets

Note: You can change one outlet first, right-click it, and use “copy” to change the rest. 

Solution→Monitors→Residual→Equations→Set all “Absolute Criteria” of residuals to 1e-5 instead of 
the default value 1e-3

Solution→Initialization→Hybrid Initialization→More Settings→Change “Number of Iterations” to 
20→Click OK→Click “Initialize” 

Solution→Run Calculation→Parameters→Number of Iterations → Type “1000”→Click “Calculate”
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You can then monitor residuals in the GUI. It took approximately 80 iterations to converge. 

You can write the case and data files: File→Write→Case and Data

Note: The steady-state airflow simulation case and data are saved and named “Airway After Setup 
Steady-State Airflow.cas.h5” and “Airway After Setup Steady-State Airflow.dat.h5”

The post-processing of the steady-state airflow field will be covered in the next segment (Part 5)

Particle Transport Simulations using Discrete Phase Model (DPM)
Since we will run particle transport in transient style, we need first to change the simulation to transient 
simulation. 

Open “Airway After Setup Steady-State Airflow.cas.h5” and “Airway After Setup Steady-State Airflow.
dat.h5” 

Read “Airway After Setup Steady-State Airflow.dat.h5”

Note: Since we will apply a one-way Euler-Lagrange model (one-way DPM) in this tutorial, which 
means that the airflow field will not be influenced by the presence of particles, we can read the steady-
state airflow field and do not need to update the airflow field during the DPM simulation. The one-
way coupled DPM is based on the assumption that the particle volume fraction is low (dilute particle 
suspension). For dense particle suspension, two-way coupled DPM needs to be employed (Feng et a., 
2021). 

Task Page → General → Time → Change to “Transient”

Enable DPM Model and Define Particle Injection
Model→Discrete Phase→Max. Number of Steps→Change it to 5000

Model→Discrete Phase →Physical Models→We do not enable any of the forces listed in this tab in this 
tutorial for simplicity, but you may need to enable some of them based on ROMA and Eq. (6) discussed 
in Part 2. Without enabling those forces listed in this tab, only drag force and gravity will be considered. 

Create particle injection through the inlet: Model→Discrete Phase→Injection→Create→The window 
shown in the snapshot below will pop up, please follow the setup in the snapshot to set a particle 
injection through inlet. 
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Note: The setup for this injection is for spherical particles with diameter equal to 5 µm and injection 
between t=0s and t=1e-6 s. 

Define the drag la Model→Discrete Phase →Injection→injection-0→Physical Models→For simplicity, 
we choose “ spherical” in Drag Law. 

Note: It is worth mentioning that the Cunningham factor may need to be enabled for small particles. If 
you need to do so, please either choose “Stokes Cunningham” in Drag Law or use UDF “DEFINE_DPM_
DRAG”. 

Click “OK”.

Now you may see the Discrete Phase model status changed from “off” to “on”. We can now define the 
inert particle material properties. 
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Define Particle Material Properties
Materials→inert Particle→double click “anthracite”→change the name to “water”  and change the 
density for the particles to “1000”→Click “Change/Create”→click “Close” (see snapshot below). 

Note: The reason we need to change the particle density to water density is based on the assumption 
that the particle diameter is aerodynamic diameter. 

Note: (1) Particle time step can be precisely controlled using UDF “DEFINE_DPM_STEP” (can be hooked 
in Discrete Phase Model→UDF→DPM Time Step), which is not covered in this tutorial. (2) For particle 
injection setup, it is highly recommended to use “file” injection with a .inj file. This will allow the 
researcher to fully control how many particles will be inhaled. The particle number density must be 
sufficiently high to reach particle number density independent” of the particle deposition pattern. 
Details can be found in Feng et al. (2021). 

Set DPM Boundary Conditions
Boundary Conditions→Inlet→Click “inlet:141”→Click “DPM” tab→Choose “escape” in “Discrete Phase 
BC Type”→Click “Apply”

Boundary Conditions→Outlet→Click “DPM” tab→Choose “escape” in “Discrete Phase BC Type”→Click 
“Apply”

Boundary Conditions→Wall→Click “wall:51”→Click “DPM” tab→Choose “trap” in “Discrete Phase BC 
Type”→Click “Apply”
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Save Transient Simulation Data
Outline View→Solution→Calculation Activities→Autosave→Calculation Activities→Click “Edit” (see 
the snapshot below)

A new “Autosave” window will pop up (see snapshot below). Please follow the setup shown in the 
snapshot below, and click OK. The setup is to save the data every 0.1 s. 

Note: Make sure the file name in “Autosave” window has the correct working directory with the .cas 
file. 
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Run Simulation
Outline View→Solution→Run Calculation→Follow the setup shown in the snapshot below and click 
“Calculate”. 

You should then have five .dat files at different flow time stations (t=0.1, 0.2, 0.3, 0.4, 0.5 s) named 
“Airway After Setup Transient Airflow and DPM-1-***.dat”. It will also save a new case named “Airway 
After Setup Transient Airflow and DPM-1.cas”.

Gas Species Advection and Diffusion Simulation using User-Defined Scalar (UDS)
In this section, we will work on a transient simulation case to simulate the transport and absorption of 
inhaled gas/vapor species as a second continuous phase, other than air. The gas/vapor species mass 
fraction will be modeled using a user-defined scalar (UDS) and the scalar transport equation (Feng et 
al., 2021) (also see Eq. (10) in Part 2). 

To be more specific, the UDS will be created in this section, representing the nondimensionalized 
mass fraction of nicotine vapor (Sperry et al., 2023). The nicotine vapor (assuming no condensation) is 
assumed to be in excess air during transport. The binary diffusivity of nicotine in great excess of the air 
at body temperature (i.e., 37 °C or 310.15 K) can be then given as 0.695e-5 m2/s (Sperry et al., 2023)

Open Ansys Fluent

File→Read→Case and Data → Choose “Airway After Setup Steady-State Airflow.cas.h5”. This step will 
allow us to start from the steady-state airflow simulation setup and result. 

Outline View→General→Task Page→ Change to “Transient” in “Time”

Note: The gas/vapor simulation in this section can be also integrated into the DPM simulation case, 
and the simulation of air, gas/vapor, and particles can be conducted simultaneously. However, for 
the simplicity purpose of this tutorial, we start from “Airway After Setup Steady-State Airflow.cas.h5” 
instead of “Airway After Setup Transient Airflow and DPM-1.cas”.
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Enable Scalar Transport Equation and UDS
Enable UDS that governed by Eq. (10) in Part 2: User-Defined→Scalars (see snapshot below)

In the new window popped up (see snapshot below), choose “1” in Number of User-Defined 
Scalars→Click “OK”. There will be an additional advection-diffusion scalar transport equation added to 
the governing equation system. The variable is UDS-0, which represents the nondimensionalized mass 
fraction of nicotine vapor ranging from 0 to 1.

Define the Binary Diffusion Coefficient of UDS-0 in Great Excess of Air
Outline View→Setup→Materials→Fluid→Air→Click “Edit” to the right of “UDS Diffusivity [kg/(m s)]”

Type “8.53825E-06” in the blank in the UDS Diffusion Coefficients window pop up (see the snapshot 
below)→Click “OK”→Click “Change/Create”→Click “Close”.
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Note: Please notice that UDS Diffusion Coefficient is kg/ (m s) instead of the diffusivity unit m2/s, which 
means the value should be ρa-g Da-g,s instead of Da-g,s.

Define UDS Boundary Conditions
Boundary Conditions→Inlet→Follow the setup shown in the snapshot below.  

Note: Since UDS-0 is the nondimensionalized mass fraction, we can set the specified value equal to 1 
at the inlet. 

Boundary Conditions→Outlet→Follow the setup shown in the snapshot below to set up all outlets 
UDS boundary conditions. 

Note: Zero specified flux indicate zero mass fraction gradient at outlets, which is reasonable. 
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Boundary Conditions→Wall→Follow the setup shown in the snapshot below to set up the wall 
boundary condition for UDS. 

Note: The setup is to reflect the Dirichlet boundary condition, which means the absorption rate is 
infinitely high for nicotine vapor on the airway wall (Feng et al., 2021) (also see Part 2).

Setup Convergence Criterion for the UDS Scalar Transport Equation
Outline View→Solution →Monitors--<Residual→Set the convergence criterion for uds-0 as 1e-6.

Save Transient Simulation Data
Outline View→Solution→Calculation Activities→Autosave→Calculation Activities→Click “Edit” (see 
the snapshot below)
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A new “Autosave” window will pop up (see snapshot below). Please follow the setup shown in the 
snapshot below, and click OK. The setup is to save the data every 0.05 s. 

Note: Make sure the file name in “Autosave” window has the correct working directory with the .cas 
file. 

Run Simulation
Outline View→Solution→Run Calculation→Follow the setup shown in the snapshot below and click 
“Calculate”.

You should then have Ten .dat files at different flow time stations (t=0.05, 0.1, 0.15, 0.2, 0.25, 0.3, 0.35, 
0.4, 0.45, and 0.5 s) named “Airway After Setup Transient Species Transport-1-***.dat”. It will also save 
a new case named “Airway After Setup Transient Species Transport-1.cas”.
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