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This tutorial uses Ansys Fluent®, the fluid simulation software.

In this tutorial segment, we will cover:

Geometry import

Mesh Size Determination

Surface Mesh Generation

Mesh Quality Check

Material Point Creation and Volumetric Region Creation
Volume Mesh Creation

Volume Mesh Quality Check and Improvement

Export Mesh

Open the Ansys Fluent software! in Meshing Mode
Import stl file: File—>Import->CAD->Load the stl file=>Click “Import”

B
+ Import Single File Append

n
File (*Ansys Case Study Preparation/Smoothest.st | ...
)

. stl file location
Length Unit  mm v

Tessellation

* CAD Faceting
CFD Surface Mesh

CAD Faceting Controls
Refine Faceting

Options...

Import lm Help

Visualize the geometry: Outline View—->Right Click “Geometry Objects”->Click “Draw All”=>If needed,
click “Fit to Window ” (button highlighted by arrow) to visualize the geometry properly.

Boundsry Mesh  Display  Report

1 This tutorial was made with the Ansys Fluent 2023 R2 release. Menus may look different, depending on which release is being used.
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You should now be able to see the geometry similar as shown in the snapshot below:

Note: ASCII format is preferred for the stl file to be imported, which will have the surfaces divided
rather than a single surface. Outlets of the geometry (small airway openings) are named as “o**”.
Airway wall is named “wall”. Trachea inlet is named “inlet”.

Note: The trachea inlet diameter is 0.016 m in this geometry.

Check “Free faces”, “multi faces”, “face edges” under Display (see snapshot below). This will help to
visualize problematic mesh cells during the diagnostic phase of mesh quality later.

Display
¥ All Faces ¥ Help Text )
| Free Faces v/ Highlight EES
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¥ Face Edges Jj | Marked Faces

Measure geometric dimensions to determine the proper mesh size for surface mesh:

Click “Node Selection Filter {__!” -Hold Ctrl on the keyboard and use the left button on the mouse to

choose two nodal points as shown in the snapshot below:
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The distance between the two nodes can be found in the Mesh window. It should be approximately
around 1.0 in this geometry. It is worth mentioning that this is just a reference geometric dimension
for people to use when determining the mesh size. It does not necessarily to be selected in the same

way shown here.

After learning the geometric dimension by checking multiple locations, we are ready to set up “Scope
Sizing” rules for surface mesh generation.

Note: The recommended Scope Sizing setup below is not the perfect mesh due to the fact that we
need to control the total mesh element number below 1 million to make sure the simulation can be

run using a free student license?.

Right Click “Model”—> Sizing = Scoped. The window below should pop up for you to set up mesh
generation criteria for surface mesh generation.

Scoped Sizing List [0/0] ?

Draw [LisLE Delete | Write...

:’; [6 Global Scoped Sizing
'— = Min Max Growth Rate
0.02316 5.92777 1.2 Apply| [Reset
Local Scoped Sizing
Name Type
control-1 curvature ~
Min Max Face Proximity Option
0.02316 5.92777 Fice Boundany
Growth Rate  Normal Angle
1.2 18
Cells Per Gap
] | Ignore Orientation
Scope
Scope To Object Faces and Edges =
Object Type
¥ Geom Mesh
Selections * ll_
Create | Modify

iReall.«]

Compute | Filters... Delete Size Field m Help
L J L8 J

2 Full licenses of the Ansys Fluent software allows for a higher number of mesh elements
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Instead of setting rules manually, please read the scope sizing file named “SurfaceMesh.szcontrol”.
Then you should see those scoped sizing rules listed in the window (see the snapshot below). Click
“Compute” first, then click “Close”.

]
= | = | [~ | Global Scoped Sizing
Scoped Sizing List [0/3] 2 l'_’: |@J Min Max Growth Rate
Inlet 0.02316 5.02777 1.2 Apply | | Reset
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Name Type
control-1 curvature ¥
Min Max Face Proximity Option
0.02316 5.92777 Face Bo

Growth Rate  Normal Angle

1.2 18

| Fa ce

Ianore Self
Cells Per Gap
3 | Ignore Orientation
Scope
Scope To Object Faces and Edges =
Object Type
¥ Geom Mesh

Selections * U
Create Modify
Draw |List| Delete |Write...||Read...

P—
Filters... = Delete Size Field m Help

Compute
We will now create a surface mesh: Outline View - Mesh Generation - Geometry Objects—>Hold Shift
keyand use the mousetoselectall surfaces—>Right click mouse—>Click “Remesh”->Choose “Collectively”

—>Give a New Object Name “airway”->Click “OK”. The surface mesh will be then generated.

Workflow

= (0 Mesh Generation
- [® Model
CAD Assemblies
+ @ Geometry Objects
- ® Mesh Objects

+ B Unreferenced

Outline View
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We always need to check the mesh quality and fix the problems before generating the volume mesh:
Right-click “airway” under “Mesh Objects”->Diagnostics—>Connectivity and Quality. A window will pop
up, as shown in the snapshot below. Click “Summary” and check the surface mesh quality report in the

console.
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The report should be similar to this:

fres-faces nulti-faces

faca-zones-Summary

duplicate-facas

skewad-facea(> 0.85)

maximim-skeawnass all-faces face-zones|

k 0.54301747

Our goal is to make sure: (1) there are “0” free-faces, multi-faces, or duplicate faces, (2) to minimize

the maximum skewness as low as possible.
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To make the number free faces to zero, follow the steps shown in the snapshot below: Face
Connectivity—>Check “Relative (Percent)”—>Enter 10, 20, 30,...90 once at a time in “Tolerance”->Click
“Apply for All” at every time the tolerance is changed.
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Click “Summary” to check the number of free faces left and the maximum skewness.

face-zonea-susmary duplicate-faces akewad=-facas (> 0.85) maxinus—akewnass all=faces face-zonas

overal l=summary a 7 0.94301747 71554 46

Reduce This Number

We will now reduce the maximum skewness. Repeat the process shown in the snapshot below. You can
always click “Summary” and check the maximum skewness.
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Sometimes, manually fixing the mesh quality is needed to improve the surface mesh. @ @
. . . . .. . i
You can click “Mark”->Click “First” to start visualizing the mesh elements with low ) &
quality (high skewness). You can manually move nodes or edges of the mesh elements A
using the tool bar shown below to improve the surface mesh quality. We will not show =
the detailed process in this tutorial due to the many diversified options you may have. |
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After reducing the maximum skewness below 0.6 (see snapshot below), we consider the surface mesh

quality now acceptable.
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Create a Material Point inside the Computational Domain: Right Click “Model”=>Material Points—>Click
“Create...” >Give the material point name as “fluid-domain”->Type in the coordinate as shown in the
snapshot below to X, Y, and Z->Preview and check if the material point is in the computational domain
or not->Click “Create”.

L]

Material Points [0/0] e (0] B cCoeate Mgteial Point

Nami ﬂu|d‘doma|n|
X Y z

60.221 4.1401 -2.644

Compute| ' Preview

H2|p
Create... List Delete Draw m Help

Note: (1) The material point is to help Ansys Fluent Meshing to determine which simply connected
volume is fluid, solid, or dead zones in the geometry. (2) You can also use the “Node Selection Filter”
(icon with a dot in the center) to choose two nodes and use their midpoint as the material point.

Outline View->Mesh Objects—>airway->right click “Volumetric Regions” —>Click “Compute”->Click
IIOKII

You should be able to see there is a domain generated under “Volumetric Regions”. It is currently
named “wall” and identified as a “Solid Domain”. We need to change the name to “fluid-domain” and
the type to “Fluid Domain”:

Right click “wall” under “Volumetric Regions ->Change Type—>Fluid Domain

Right click “wall” under “Volumetric Regions ->Manage—>Rename—>Change the name to “fluid-
domain”.
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Outline View—>Model->Mesh Objects—>Volumetric Regions—>Right click “Cell Zones”—>Click “Auto

Mesh”. A window will pop up (see snapshot below)

For this tutorial, we will generate a tetrahedral mesh with near-wall prism layers. This window can also
generate other types of meshes, but they will not be presented in this tutorial.

In the Window: Uncheck “Keep Solid Cell Zones”, then choose “scoped” in Grow Prisms—>Click Set

Note: The reason to generate near-wall prism layers is to control y+ to make sure that the near-wall

1]
Auto Identify Volume
Object

airway - :Draw;
¥ Keep Solid Cell Zones
Keep Dead Cell Zones
Boundary Layer Mesh
Grow Prisms none v | |Set...
Quad Tet Transition

* Pyramids
Non Conformals | Set...

Volume Fill Volume Fill Options
* Tet Cell Sizing
Hexcore Size Field * Geometric
Poly

Growth Rate 1.2
Poly-Hexcore

i Max Cell Length
a 2.47281 Compute)

Set...

Options
Merge Cell Zones within Regions

Mesh. Apply Help

mesh meets the requirement of different turbulence models (e.g., Transition SST) if transitional flow
or turbulence needs to be modeled (Feng et al., 2021).

Follow the setup shown in the snapshot below and click “Create”—>Click “Close”. The prism layers will

be only grown on walls, not necessarily for inlet and outlets.

Note: You can also read the scoped sizing file named “NearWallPrismLayers.pzmcontrol” for the near-

wall prism layer setup.
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scoped prisms List [0/0] (% (5] (@) l-NcZ':’em_ :

Parameters
Offset Method
aspect-ratio bt
First Aspect Ratio  Number of Layers
10 5 -
Last Aspect Ratio  Rate
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Scope
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Volume Scope | *
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Boundary Scop{wall LB
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Write ... [Read

=)
Growth Options... |

ol c.... |ET

Back to the “Auto Mesh Window”—->Make sure to check “Merge Cell Zones within Regions”, unless you
prefer to have the prism-layer region as a separate domain in Ansys Fluent Solver.

1
Auto Identify Volume
Object
airway - [Draw]

Keep Solid Cell Zones
Keep Dead Cell Zones
Boundary Layer Mesh

Grow Prisms  scoped v [Set._.]

Quad Tet Transition

* Pyramids
Non Conformals | Set...
Volume Fill Volume Fill Options
® Tet Cell Sizing
Hexcore Size Field * Geometric
Fol
polv " Growth Rate 1.2
-hHexcore
8 'r‘ Max Cell Length ——
2.47281 Compute|
|set...

[ " Merge Cell Zones within Regions ]
¥ Auto Partition (Parallel Meshing)

Mesh J Apply J m

In “Auto Mesh” Window —>Click “Apply” -Click “Mesh” to generate volume mesh.

You should then have the volume mesh generated and you may see that the near-wall prism layers
were generated by visualize the mesh again using Mesh Generation->Mesh Objects—>Right click “Cell
Zones” = “Draw All Boundaries”. (see the snapshot below)
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You can also check the volume mesh by enabling “Insert Clipping Planes” and “Draw Cell Layer” (see

the snapshot below).

Clipping Planes Mouse Probe Function Display
«l Insert Clipping Planes | Show Cut Edges + Draw Cell Layer = Select ¥ All Faces ¥ Help Text

Box Free F ! Highlight
q ¥ Freeze Cell Layer s e
Polygon Multi Faces ¥ Edge Zones
PR [ ! Fli
Limit in X ® Limit in ¥ O Limit in Z p Select Visible Entities | ¥ Face Edges (| Marked Faces
Mesh
stion Filter

se button is not mapped to mouse probe |

Outline View—>Model->Mesh Objects—>Right Click “Cell Zones”->Summary

Note: The goal is to check the minimum quality and improve it.
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Outline View->Model->Mesh Objects—>Right Click “Cell Zones” - Auto Node Move->Play with “Quality
Limit” and “Auto Correction” to improve the volume mesh quality.
L]

Parameters Cell Zones

A"zoms :
RRE

Boundary Zones [46/92]

Max Iter/Node
50 - inlet -
Dihedral Angle II'.Ihtidl .
o
120 B
o10:137 -

+ Restrict Boundary Nodes Along Surface

Semi-Auto Correction

Iterations
5

Skew Next Skew Reset Skew

Propose Accept Refuse

nppll,r.

!Quality Measure

Improve Warp

Repair Negative Violume Cells

3 ()
The mesh quality was improved with a minimum quality equal to 0.2688.
name id cells (quality < 0.1) minimum quality cell count
fluid-domain 2587 0 0.26877599 561571
name id cells (quality < 0.1) minimum gquality cell count
Overall Summary none 0 0.26877599 561571

File>Write->Mesh. You will have a .msh.h5 file for Ansys Fluent Solver. The mesh should contain
approximately 560,000 elements (cells).

Note: The .msh.h5 file can also be read by Ansys Fluent Meshing again with all setups saved.

Note: In this tutorial, we only generated one mesh. However, for research, a mesh Independence test
is necessary. Details about how to conduct a mesh independence test can be found in Feng et al (2021).

Feng, Y., Zhao, J., Hayati, H., Sperry, T., Yi, H. (2021). Tutorial: Understanding the transport, deposition,
and translocation of particles in human respiratory systems using Computational Fluid-Particle
Dynamics and Physiologically Based Toxicokinetic models. Journal of Aerosol Science, 151, 105672
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