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Summary

Ansys Fluent is a comprehensive computational fluid dynamics (CFD) software that allows you to model 
fluid domains.

In this set of tutorials, we will introduce basic functionalities of Ansys Fluent through the Ansys 
Workbench interface. Ansys Workbench is the integration and workflow platform that connects Ansys 
products. 

This tutorial will cover the very basics on how to create or import geometry, create a basic mesh, apply 
boundary conditions, and perform solutions setup and post analysis of your first CFD simulation.

This tutorial is #1 of a seven-part tutorial series that serves as an introduction to Ansys Fluent. Details 
of the topics covered and the order can be found in the table below. These tutorials build on one 
another, so it is recommended that they are followed in order. Other tutorials can be found on the 
Ansys Education Resources site. 

*This tutorial was created using the 2023R1 Student Version of Ansys Workbench. Some screens may 
look different, depending on your version. Check the Ansys Learning Forum if you have any questions.
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Starting a Project in Workbench
Begin by opening Ansys Workbench. Once Ansys is loaded, you will be interfaced with the following 
screen: this is your workbench. Down the left side of your screen, you will see a series of simulation 
packages offered by Ansys. For this exercise, we will use “Fluid Flow (Fluent).” To select “Fluid Flow 
(Fluent),” drag the listed option out of the analysis systems tab into your project “schematic.”

To complete a fluid flow (fluent) solve, you will need to provide the following:
1.	 Geometry - Either created using Ansys Discovery or imported from a CAD program.
2.	 Mesh - A mesh defining the fluid domain into a finite number of cells.
3.	 Setup - Defining the boundary conditions, Solution methods and report functions.
4.	 Results - Post solution analysis, Contours, Streamlines, vectors and much more
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Exercise 1: Simple 2D Turbulent Pipe Flow
As mentioned earlier, the first step in any CFD application is to develop or define your geometry. To 
start, we will determine the type of simulation we are conducting, whether it’s 2D or 3D. To define the 
geometry as 2D, follow these steps:

1.	 Click on the “Geometry” tab once, and a series of options will appear on the right side of the 
screen.
2.	 Under “Advanced Geometry Options,” change the “Analysis Type” from 3D to 2D.

Once that has been done, we will open the geometry interface. There are a few different modeling 
options we can use:

•	 Ansys SpaceClaim1 is a non-parametric modeling program, which can be used to construct new 
or alter externally constructed models. Being a non-parametric program makes it quick and easy to 
adjust complex geometry.
•	 Ansys Discovery is a non-parametric modeling program that Ansys has developed, very similar 

to SpaceClaim but integrated solving. 

For this course we will be using SpaceClaim. Right click on the geometry tab and select “New Geometry 
in SpaceClaim” and wait for the Interface to load.
By default, when you begin sketching, it will be on the XZ plane. However, for a 2D geometry, we need 

to create a surface on the XY plane to ensure Ansys recognizes it as 2D in Fluent. To achieve this, follow 
these steps:
	 1. Select “End Sketch Editing” in the “Sketch” tab to complete the current sketch.
	 2. Now, choose the “Sketch Mode” and select the XY plane, as illustrated in the figure below. 
This will allow you to create a 2D surface that Ansys will recognize for further analysis in Fluent.

 

1 After the 2023R1 release, Ansys SpaceClaim became a legacy product and Ansys Discovery  (a simulation-driven design 
tool that combines instant physics simulation, high fidelity simulation and interactive geometry modeling in a single easy-
to-use experience) became the primary built-in Geometry tool. If you want to learn more about specifically modeling in 
Ansys Discovery, check out this Ansys Innovation Course “Learn Solid Modeling with Ansys Discovery”.	

https://courses.ansys.com/index.php/courses/solid-modeling-ansys-discovery/?utm_campaign=academic&utm_medium=referral&utm_source=education-resource&utm_content=partner_cross-bu_educator-resource-link_course-aic_learn-more_na_en_global&campaignID=7013g000000gv7hAAA
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To center the working plane, select the plane you are working on using the bottom left coordinate

Now, we may begin sketching. First, select the “Rectangle” icon located in the sketch tab. Draw a 
rectangle on the XY plane with the dimensions of 100x1000mm, as shown below. To ensure precise 
measurements, you can utilize the “Dimension” tool in the sketch tab to add appropriate dimensions 
to this sketch.

Once you are satisfied with your sketch, press “End Sketch” in the sketch tab. You will notice that in 
your model tree, a surface is created, and the sketch will appear green, indicating its completion.
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Once the geometry has been created, close SpaceClaim and return to the main Workbench interface. 
Now, open the “Mesh” tab in the Fluid Flow (Fluent) Analysis System. After accessing the meshing 
application, you will be presented with the following interface. This is where you can perform meshing 
operations on your geometry to prepare it for further analysis in Fluent.

We will begin by generating the default mesh. To do this, select “Generate” in the home tab. Once you 
do so, you will be presented with the following coarse mesh.

 
Now, we want to refine the mesh to achieve a more accurate simulation. For this session, we will use 
a basic meshing approach. In your model tree, click on “Mesh,” and you will notice a series of options 
appear at the bottom of the model tree. Proceed to “Defaults” and change the “Element Size” to 5mm. 
After making this change, hit “Generate” again. You should now see the following mesh, which is more 
refined and will provide improved accuracy for your simulation.

Now, we will improve the boundary conditions of the pipe. To do this, we will first apply “face meshing,” 
which will allow us to keep the face mesh as quadrilateral cells. To do this, right-click on “Mesh” -> 
“Insert” -> “Face Meshing.” Scope the geometry to the face of the pipe, as shown in the image below.
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Now, we will add “Edge Sizing” to the inlet and outlet of the pipe. We will set the number of divisions 
to 100 and add a bias to get more cells at the boundary layer of the pipe. To do this, right-click on 
“Mesh” -> “Insert” -> “Sizing.

Under the ‘Details Sizing,’ click on ‘Geometry’ and scope it to the 
Inlet and Outlet, as shown in the images above and below. Under 
‘Definition’ -> ‘Type,’ change it to ‘Number of Divisions’ and set 
it to 100 divisions. After completing this step, we will add a ‘Bias 
Type’ under ‘Advanced’ and change it to ‘- --- ----- --- -‘Then, add 
a ‘Bias Factor’ of 2.0. This will bias the cells across the boundary 
layer, causing them to bunch up in spots we deem more critical.”

Once you have finished setting up the mesh, navigate to the 
“Home” tab and click on “Generate.” The mesh should now be 
displayed as shown below.
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Before exiting the “Mesh” section, we need to define the Inlet, Outlet, and Walls of the domain. To do 
this, right-click on the model tree and choose “Named Selection.”

To select an edge, you will need to use the edge selection tool. You can find this option in the top bar 
above the geometry. The image below illustrates where you can locate this option. Once you select an 
edge, it will be highlighted in green. Now, you can add this selection to the “Geometry” section seen at 
the bottom left of the screen under “Scope” -> “Geometry”. This process allows you to define specific 
regions in your mesh for further boundary condition assignments in Fluent.

Once you have defined the edge, you must rename the “selection” to “Inlet.” This action will inform 
Ansys that we intend to designate it as an inlet in the boundary conditions when setting up the solution. 
After defining the inlet, you need to repeat the same process for the outlet and the walls of the domain.
The following image illustrates how all three named selections (“Inlet,” “Outlet,” and “Walls”) should 
look like:
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To select multiple edges simultaneously, hold down the “Control” key and click on the edges you wish 
to include in the selection. This will allow you to efficiently define the named selections for various 
parts of the geometry in your mesh, facilitating the setup of boundary conditions for the subsequent 
solution in Fluent.

Now that you have completed the meshing process and defined 
your named selections, you can close the “Mesh” interface. 
However, before proceeding to the “Setup” stage, it is essential to 
“Update” the mesh. To do this, right-click on the “Mesh” tab and 
select “Update.” This step ensures that any changes made to the 
mesh are applied and up-to-date for the subsequent setup and 
analysis in Fluent.

NOTE: Ansys student licenses have cell limitations. Please check 
out the Ansys Student Download page to confirm Problem Size 
Limits for the current release.

Once the Workbench has finished updating, you will notice a green tick displayed over the “Mesh” tab. 
Now, you can proceed to open the “Setup” tab. Upon selecting this tab, you will be presented with the 
following interface, where you need to specify a few options before continuing with the solution setup.

The first step is to enable “Double Precision,” as this setting will help reduce computational time and 
enhance accuracy. The other necessary setting is to define the number of logical processors. As Ansys 
limits the licenses to 4 processors, you should enter “4” in this field.

After making these changes, click on “Start” to initiate the setup process. This will configure the 
necessary parameters for your simulation, preparing it for the solution stage in Fluent.

https://www.ansys.com/academic/students/ansys-student
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Note: logical processors are defined in you task manager, but for rule of thumb it’s the number of 
threads on a CPU not the core count. Typically, CPU’s have two threads for each core, so a four-core 
CPU will have 8 logical processors.

Once you enter the solution interface, you will notice a series of options listed down the left side. We 
will gradually progress through this list, though some options may be skipped for now. I encourage you 
to explore this interface to become familiar with its capabilities. 

The first step is to define the type of CFD analysis you will be conducting. For today’s lab, we will 
perform a steady-state pipe flow analysis. By default, the steady-state option should be selected, but 
it is essential to ensure that the steady-state option is ticked.

Next, you need to define the effect of gravity in your analysis. To do this, tick the “Gravity” option and 
since the pipe runs along the X-axis, we will define the gravity in the Y-axis. Enter the value “-9.81” 
in the corresponding text box to represent the acceleration due to gravity in the Y-direction. This will 
account for the gravity effects in your steady-state pipe flow simulation.

The next thing we need to define is the type of equations that will govern this simulation. We will go 
into detail later on how to select and what to select for the type of simulation you want to achieve. But 
for now, we will be using the “SST K Omega” option. Navigate to the “Models” tab, select “Viscous,” 
and tick the “SST K Omega” option. Press “OK.” This should be set by default, but if not ensure this is 
set correctly.



© 2024 ANSYS, Inc.11

Following this, you can move to the material selection. We will be simulating the flow of water through 
the pipe. By default, only air is loaded as the material, so we need to add water (H2O) to the material 
list from the Ansys database. To do this, navigate to “Materials” -> “Fluids” -> Click and open “Air.”

To add water, click on “Fluent Database,” and scroll down the list until you find water. Select water and 
press “Copy.” You will notice that water now appears under the “Fluid” option in the tree. You may now 
close the materials tab.
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We need to define the fluid going through the pipe, and by default, it is air. To apply water as the fluid 
domain, we need to navigate to “Cell Zone Conditions” -> “Fluid” -> “Surface.” Select “Material Name” 
and switch it from “Air” to “Water.” Press “Apply” and close the window.

Following this, we need to define our boundary conditions, including the inlet, outlet, and walls. If 
the named selections from the “Mesh” tab were defined correctly, the boundary conditions tab will 
automatically set the inlet as “Velocity Inlet,” the outlet as “Pressure Outlet,” and the walls as “No Slip” 
wall conditions.

To proceed, open the “Inlet” tab and define the fluid speed as 1m/s. Press “Apply” and close the 
window to confirm the specified boundary conditions.
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Now that we have defined our boundary conditions and solution methods, we can proceed to the 
“Initialize” tab. Select “Standard Initialization” and compute it from the “Inlet.” Set the X velocity to 
1m/s and the rest of the initial values to 0. Once you have set these options, initialize the simulation. 
This process will prepare the simulation by setting the initial values for the variables, allowing you to 
proceed to the solution stage.

Move over to the “Run Calculations” tab. The solution will iterate until the number of iterations has 
been reached or the solution has converged. We will discuss how to change the convergence criteria 
in later weeks, but for now, we will leave it as is. For today’s simulation, the only thing you need to do 
before running the simulation is to specify the number of iterations you would like to simulate. Set 
“Number of Iterations” to 100 and press “Calculate.” This will initiate the simulation and perform 100 
iterations.
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You will notice in the console that it is now running and iterating over each solution. If you select 
the “Scaled Residuals” graph, you can observe how the solution progresses towards its convergence 
criteria. The graph will show the variation in residuals of the solution as it converges to a steady 
state or the specified convergence threshold. Monitoring the residuals is a helpful way to assess the 
convergence and stability of the simulation during the iterations.

Now, before we move over to the ‘Results’ tab, we will look at the velocity and pressure contours to 
see if they make sense. The only difference between analyzing the results here and in Post CFD is that 
we get a few more options to review and edit our results, create movies, etc.

To create a contour of the domain, you must go to ‘Results’ -> click on ‘Contours,’ and you will be 
shown the following interface.

To create a contour, make sure “Filled,” “Node Values,” and “Auto Range” are the only boxes ticked. The 
first contour we will check is the static pressure. Create a contour of “Pressure” -> “Static Pressure.”

Click “Save/Display,” and this will show you a contour of static pressure throughout the pipe, as seen in 
the image below. You can modify the range it displays as well as whether the contour shows as banded 
or smooth. Feel free to explore the options and customize the visualization to your preferences.
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Now repeat the above step but create one for “Velocity Magnitude”.

After generating the velocity magnitude and static pressure contours, compare these values to the 
ones you have simulated to check if they make sense and align with your expectations.

Once you are satisfied with the contours and have compared them with the results obtained above, 
you can proceed to the “Results” tab. When you open this tab, you will be presented with the following 
user interface (UI). In this interface, you will have access to additional options to review, analyze, and 
manipulate your simulation results, including creating animations and exploring various visualization 
tools.

To create a contour in “Post CFD,” click the button that is boxed in the above image. You will be prompted 
to name the contour, and then you will be presented with options at the bottom left corner, as shown 
below. These options allow you to customize the contour visualization and explore the results in more 
detail.
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This process in “Post CFD” is indeed very similar to what we did before in Fluent but in a different 
interface. We want the contour to show “All Domains” and be at the location of “Symmetry 1” to allow 
us to see the pressure contours throughout the pipe.

Again, like before, we will create a pressure contour. Change “Variable” to pressure and click apply. 
We can further refine the contour by increasing the number of contour bands. This can be changed by 
modifying “# of Contours.”

Create a contour for both pressure and velocity and compare the results below. This comparison will 
help verify the consistency and accuracy of the simulation results.



© 2024 ANSYS, Inc.17

Do these results make sense? How could we improve them?

You can save the contours as an image by going to “File” -> “Save Picture.” This will present you with 
the following options:

You can specify the file save location with the file icon, and once done, just press “Save.”

Congratulations on completing your first CFD simulations! Now, you can explore further by trying to 
improve the mesh and see how it affects the results you have obtained. Mesh refinement can have 
a significant impact on the accuracy and reliability of the simulation, so experimenting with different 
mesh settings and resolutions can help you achieve more accurate and detailed results in your future 
CFD simulation.  
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