Tips and Tricks: Design Modeler & ANSYS Meshing

June 13th 2013

Andy Wade
andy.wade@ansys.com
This presentation will highlight several common challenges for preprocessing, and provide best practices to utilize ANSYS solutions to address some of these issues:

- Speed of operations with GUI
- Visualisation/understanding of geometry
- Finding geometry overlaps
- Re-use of mesh settings for a new model
Usability Features in DM
Problem statement: *Too Many Clicks!*

- **User Problem** – It can take many clicks of a mouse to achieve the desired function

- The following will show recent usability enhancements to significantly speed up operations in Design Modeler
Middle-Mouse Multi-Options

View Options can be accessed via toolbar

- Rotate
- Pan
- Zoom

- Much quicker is Middle Mouse Button (MMB) with key changes
  - Rotate
  - Shift + MMB : Zoom
  - Ctrl + MMB : Pan
Quick Toggle Single/Box Select

- Often it is useful to use Box Select to lasso lots of entities quickly.
- User may wish to then use Single Select to add or remove a few entities while holding down Control key.
- There is a “quick toggle” option to move between these modes more quickly without having to navigate the toolbar.
  - Hold down RMB and click and release LMB while still holding RMB to switch between modes.
Design Modeler Hot Keys

- **Escape**: equivalent to New Selection (if button is not grayed out); also accessible via the Selection Toolbar
- **Ctrl+A**: selects three Body Types: Solid, Surface, and Line
- **Ctrl+B**: equivalent to Selection Filter: Bodies (also accessible via the Selection Toolbar)
- **Ctrl+C**: equivalent to Copy (Sketching mode only; also accessible via the Modify Toolbox)
- **Ctrl+E**: equivalent to Selection Filter: Edges (also accessible via the Selection Toolbar)
- **Ctrl+F**: equivalent to Selection Filter: Faces (also accessible via the Selection Toolbar)
- **Ctrl+N**: equivalent to Start Over option (also accessible via the File Menu)
- **Ctrl+O**: equivalent to Load DesignModeler Database option (also accessible via the File Menu)
- **Ctrl+P**: equivalent to Selection Filter: Points (also accessible via the Selection Toolbar)
- **Ctrl+S**: equivalent to Save Project option (also accessible via the File Menu)
- **Ctrl+V**: equivalent to Paste (Sketching Mode only; also accessible via the Modify Toolbox)
- **Ctrl+X**: equivalent to Cut (Sketching Mode only; also accessible via the Modify Toolbox)
- **Ctrl+Y**: equivalent to Redo (Sketching Mode only; also accessible via the toolbar)
- **Ctrl+Z**: equivalent to Undo (Sketching Mode only; also accessible via the toolbar)
- **F1**: ANSYS Inc. online help with DesignModeler highlighted; for more information, see Help Menu
- **F2**: Install help
- **F3**: Apply (during feature creation; for more information, see Apply/Cancel in Plane)
- **F4**: Cancel (during feature creation; for more information, see Apply/Cancel in Plane)
- **F5**: equivalent to Generate (also accessible via the 3D Features toolbar)
- **F6**: equivalent to Shaded Exterior and Edges, Shaded Exterior, and Wireframe model appearance controls (toggle between three; also accessible via the View Menu)
- **F7**: equivalent to Zoom to Fit (also accessible via the Rotation Modes Toolbar toolbar)
- **Ctrl++**: Expand selection
- **Ctrl+-**: Shrink selection
Problem statement: *Hard to See!*

- User Problem – Requirements to visualise more easily areas of the geometry and understand issues quickly

- The following will show recent usability enhancements to improve visualisation capability in Design Modeler
Toolbars: Display Controls

Edge Display Options

- Free Edges - 0 face - Blue
- Single Edges - 1 face - Red
- Double Edges - 2 faces - Black
- Triple Edges - 3 faces - Pink
- Multiple Edges (>3) - Yellow
- Display Edge Direction
- Display Vertices

Note user can use Share Topology option in DM to check connectivity before proceeding to Meshing.
### Toolbars: Selection Tools

**Entity Selection Mode**
- New Selection
- Single Select
- Box Select
- Select Points
- Select Edges
- Select Faces
- Select Bodies
- Extend Selection for multiple entities –

**Hotkeys**
- Ctrl+: Expand selection
- Ctrl-: Shrink selection
Problem statement: *Finding Body Overlaps*

- **User Problem** - Early versions of Design Modeler did not have the capability to find overlapping bodies.

- **The following will show usability enhancements to find overlaps**
Enabling Beta Features

• To activate “Beta Options”, go to Workbench Schematic Page
  – Go to Tools → Options
  – Select “Appearance” from tree
  – Scroll down and enable the check box of “Beta Options”

• This will activate beta features available in the Design Modeler such as “Body Clash Detection” and “Solid Extension”
Identifying Body Interferences

- Switch to Wireframe view for better viewing of clash
- [Main menu] View → Wireframe
- Locate various clashes in the geometry as shown
- In this e.g. both cases involve a compressor casing
- Adjusting/moving casing may solve problem
Usability Features in AM
Problem statement: Design Templates

User Problem: Does your department work on common components with similar boundary conditions, simulation studies, etc. but for each design change or new model, you find yourself (or others in your group) repeating the steps for CAD cleanup, meshing, simulation setup, etc.?

Would you like to automate this process, but don’t feel you have the skills to script or program a solution?

The following approach will demonstrate how Workbench can be used to “templatise” your work without having to know any scripting or programming language. It simply requires setting up the model in a way that can be repeated for other similar geometries.
Using Workbench as a “Design Template”

- Workbench can be used to setup a parametric/persistent simulation that can be used as a template for similar models.
- The idea is to define all settings you will need for a real model or case of models using a trivial model as the starting point.
- Let’s call the trivial model, the template.
- Once the template is created, you can swap out the template model for a real model, and update the project.
- Since the update can be done in batch, this is an excellent way to speed up Simulations on complex models.
- The main “trick” here is using named selections and parameters effectively.
Using a “template model”

Use named selections to define all local properties on the “template model”, and then bring in a CAD model with those named selections defined. Workbench can later generate a mesh and simulation on the real model.

For example, I can set up my template on this box, and then use it for a real model:
Set up the “template model”

1. When using a template model, run the full simulation (meshing/solve) so that all settings are persistent for when the real model is used. Note: the results in the template model do not have to make sense.

2. The starting point is the file import, so you want the template model and real model to have a similar starting point. After setting up the model, save it for later use with replace.
Set up the “template model”

3. Mesh the model using Named selections: For example, use program controlled inflation, mesh sizings on hands, face, etc

• Notice that in the template model, the face and hands are just arbitrary selections.

• In the setup, you should take this into account and apply a setup that makes sense for the real model.
Set up the “template model”

3. Mesh the model using Named selections: For example, use program controlled inflation, mesh sizings on hands, face, etc

- For example, you might want element sizes to be applied to control the meshing, but the sizes could be a variable. In the template model, you can use parameters to associate things in a nice way:

By making the Element size a parameter, it shows up in parameter manager, and you can adjust it from there where it directly correlates to any faces in the named selection.

Note: in real model there are many faces in this named selection.
Set up and use the “template model”

4. Solve the model using Named selections: For example, Inlet, Outlet boundary conditions, etc.

5. When finished save the WB project. The project is now a template.

6. This template can be shared across team with a simple set of rules:
   - What Named Selections need to exist
   - What parameters relate to what values
   - Etc.

7. To use, open WB project (Template) and replace the model with a model that follows these rules, change any necessary parameters, and Update Project.
Persistent Named Selections by “Rules”

- We can create Named selections for all entities of same size for example
- When we click on the NS in the tree we get a Worksheet
- We can RMB and add/remove “rules” to define the NS
  - E.g. to apply NS to entities over a range of sizes if there are slight differences between them

<table>
<thead>
<tr>
<th>Action</th>
<th>Entity</th>
<th>Criterion</th>
<th>Operator</th>
<th>Units</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Face</td>
<td>Size</td>
<td>Equal</td>
<td>m²</td>
<td>0.01</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

NS Based on Face Area = 0.01 m²

<table>
<thead>
<tr>
<th>Action</th>
<th>Entity</th>
<th>Criterion</th>
<th>Operator</th>
<th>Units</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Face</td>
<td>Size</td>
<td>Greater Than</td>
<td>m²</td>
<td>9.8e-03</td>
</tr>
<tr>
<td>Remove</td>
<td>Face</td>
<td>Size</td>
<td>Greater Than</td>
<td>m²</td>
<td>1.02e-2</td>
</tr>
</tbody>
</table>

NS now Based on 0.0098 m² < Face Area < 0.0102 m²

Hit Generate when finished editing Worksheet
Named Selections to Assist Meshing

- Sometimes we wish to create NS purely for mesh settings (sizing, inflation etc)
- Do not want to see these in solver!
- Need to avoid NS overlaps as well
- To do this we simply set the option “Send to Solver” to No and the NS is not passed into the solver
Questions?
Appendix
Toolbar Customization

- Add common operations to your toolbar to speed up feature creation

- Tools → Options → Design Modeler → Toolbars to add the most used options to your GUI layout
Working on Areas of the Geometry

- Reduce the display to work effectively on smaller areas using Hide/Expand options

Or use Hotkey Ctrl+-

Switch off

RMB

Hide All Other Faces
Expand Face Selection
Shrink Face Selection
Hide Body
Hide All Other Bodies
Suppress Body
Named Selection
Generate

Frozen Body Transparency
Tools ➔ Options ➔ DM ➔ Graphics

Default Highlight Selection = Single Side only “fills” surface in direction of surface vector when chosen

Switching to “Both Sides” is recommended for CFD where inner surfaces are often required. This option will show the selected face as “filled” from both directions.
Handling of Multi-Body Parts

- A regular support question is how to get conformal meshes from DM/AM
- In DM, where Shared Topology is set to Automatic (default)
  - Faces in contact imprinted & fused to form a single face shared between the two bodies
  - Results in Conformal mesh in Ansys Meshing
  - Common face acts as ‘Interior’ zone in Fluent
Handling of Multiple Parts

- When multiple parts are attached to a Meshing session a ‘Contact Region’ is automatically created between those parts
- 2 Faces at Contact Region
- Each part meshed independently
  - Results in a non-conformal interface between the two parts (mesh nodes on bodies do not line up and are not connected)
  - Grid Interface in Fluent or GGI in CFX can be defined for the faces at the contact region
Handling of Multi-Body Parts

- In DM, where Shared Topology is set to Imprints
  - The boundaries of the faces at contact region are imprinted on each other resulting in ‘like’ faces
  - Contact Region is automatically created at ‘like’ faces
  - Results in Non-conformal interface
  - Grid Interface in Fluent or GGI in CFX can be defined for the faces at the contact region
  - To create identical mesh on the ‘like’ faces use ‘Match Control’ option (mesh will remain unconnected)
Filtering allows project tree to be limited to relevant data depending on filter. Filters include:

- **Name**: Filter out objects that don’t contain a given name.
- **Tag**: Use tags to mark things, can later be filtered
- **Type**: of data
  - All, Results
- **State**: of data
  - All, Not suppressed, Suppressed, Underdefined, Not licensed
Model Views

- Ability to create and delete views:
  - A view is an orientation and zoom level

- Ability to apply, rename or replace a view

- Ability to load/save views:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<ModelViewManager>
  <ModelView Name="View 1">
    <LocX>0.122634714456706</LocX>
    <LocY>0.122838551155134</LocY>
    <LocZ>0.19619530438116</LocZ>
    <UpVX>-8.68599718556584E-02</UpVX>
    <UpVY>0.173719914088304</UpVY>
    <UpVZ>-8.68599718556584E-02</UpVZ>
    <ZoomF>0.957142857142857</ZoomF>
    <Angle>55</Angle>
    <ZoomSX>0</ZoomSX>
    <ZoomSY>0</ZoomSY>
    <FocX>-2.03812494874001E-04</FocX>
    <FocY>-3.72529029846191E-09</FocY>
    <FocZ>7.3356774295801E-02</FocZ>
    <ViewX>0.57735022543374</ViewX>
    <ViewY>0.577350356701388</ViewY>
    <ViewZ>0.577350225433739</ViewZ>
    <RotAngle>-1.90909591041642E-06</RotAngle>
    <ZoomDistance>0.10601742914592</ZoomDistance>
  </ModelView>
</ModelViewManager>
```
Section Plane by Coordinate System

• To “place” a section plane select entity or entities (vertices, edges, faces, etc) and RMB ➔ Create Coordinate System

• RMB on new coordinate system in tree and choose Create Section Plane
Recommended Graphics Options for CFD

- ANSYS Meshing shares some of its options with the Mechanical tool and graphics options must be changed here.

Set Display Options

- From the Main Menu, select Tools → Options.
- In the Options Panel expand Mechanical and select Graphics.
  - Set the Highlight Selection option to Both Sides and click OK.
  - Does the same job as in DM.
In R14.5 we can choose “Manual” Mesh Visibility and use “Show Mesh” button to switch on/off to avoid visualizing the mesh every time we want to e.g. calculate quality statistics.
Object Generator

- Object generator allows user to copy objects attached to 1 object to several.
- With mesh controls it provides an easy way to assign similar controls to a group of objects. For example:

In this example multiple mesh controls are used to define mesh for 1 part.

But there are 4 similar parts Object Generator allows you to copy the controls to 3 other parts in easy fashion.
Object Generator

- Object generator copies selected control to selected bodies:

Source Faces come from a Named Selection. This could be created based on instance information if it exists, or similar sized faces, etc.

Inflation, match, etc. controls could be generated in same manner.
Edge biasing with Smooth Transition

Added new “Bias Option”

• **Bias Factor:**
  – Same as in past
  – Max/Min edge length
  – Less intuitive

• **Smooth Transition**
  – Bias Growth Rate
  – Bias Growth Rate = Bias Factor \(^{(1/(n-1))}\)
  – More intuitive, i.e. 1.2 = 20% growth
Failures in Meshing - Diagnostics

• Always try to “show problematic areas” from the errors/warnings and investigate the areas in CAD/DM/AM to understand causes and rectify.

• Failures in meshing can give sometimes unclear error messages and ANSYS plan to improve diagnostics in the future versions.

• Isolate problematic bodies and try various options:
  – Color edges by connection to check connections are correct between bodies.
  – Use cleanup tools in DM to check for problems (suppress other bodies) with identified problematic bodies.
  – Use the Tools ➔ Analysis Tools ➔ Fault Detection to check for problems.
  – Use edge/face operations to fix problem areas.
  – Use Extrusion/extension tools to close small gaps.
  – Simplify body/bodies in DM/Spaceclaim/CAD (Body Operation ➔ Simplify).
  – Try other methods for meshing to see if they work on problematic body (patch independent tet or assembly meshing may help if connectivity problems occur).
  – Change the Mesh Based Defeaturing tolerance or switch off altogether to see if that is causing problems.
  – Alter the min size in your problem to see if that resolves the issue.
Contacts for Auto-Non-Conformals

Do not form a multi-body part if you require non-conformal interfaces between bodies.

- Contacts are automatically generated in Meshing.
- Drag “Contact Region” onto “Mesh” part of tree to create “Contact Sizing” to apply similar size on both bodies at the contact patch to improve interpolation accuracy.

- In Fluent/CFX the contact regions automatically create Mesh Interfaces/GGIs with no user input required. Non conformals require some interpolation but can allow for very high quality mesh in some cases which can offset this accuracy penalty.
Assembly Meshing with Cutcell

- Assembly Meshing works on a tessellated version of the geometry which is passed to the TGrid libraries to mesh.
- Refinement of this tessellated geometry can be controlled in 2 ways
  - Via tessellation refinement
  - Via CAD tessellation settings
    - In DM this means the Graphical Facet Quality can affect the mesh
    - Increase the Facet Quality to 10 to improve curvature representation for assembly meshing
Parallel Processors

- Speed up quality computations using parallel processors
- Under Workbench settings
Selective Meshing

What is Selective Meshing?
• Selectively picking bodies and meshing them incrementally

Why use Selective Meshing?
• Bodies can be meshed individually
• Mesh seeding from meshed bodies influences neighboring bodies (user has control)
• Automated meshing can be used at any time to mesh all remaining bodies
• When controls are added, only affected body meshes require remeshing
• Selective body updating
• Extensive mesh method interoperability
Selective Meshing

Local meshing
• Mesh or clear meshes on individual bodies
• Subsequent bodies will use the attached face mesh
• The meshing results (cell types) will depend on the meshing order
• Adjust/add controls – able to remesh only affected body
• Select body(s) right click for context menu

Meshing first the pipe then the block

Meshing first the block then the pipe
Selective Meshing

Recording Mesh Operations

- When using selective meshing the order of meshing can be recorded for automated future use
- Right click Mesh in the Outline for Context Menu

- Worksheet is generated recording mesh operations as ordered steps
- Named Selections are automatically created for each meshed body for reference in the Worksheet
  - Example; Meshing cylinder then block
Selective Body Updating

- Remeshing only bodies that have changed
- Access option through Tools > Options
  - No: All geometry updated, all bodies remeshed.
  - Associatively: Accommodates for body topology change (add/delete) (slower)
  - Non-Associatively: Assumes no topology change (faster)
- Example; Geometric change to block.
1. Create plane from surface then sketch

2. Sketch closed refinement shape in 2D

3. Extrude into 3D (frozen) and leave refinement region as separate part!

4. Select body and RMB (while in Mesh part of tree) Insert → Body Sizing. Choose Body of Influence

Final mesh has nice, user-defined refinement region
Problem statement: Visualisation

Is your geometry complex and picking or visualising the areas of interest for some meshing operations difficult?

The following discussion will demonstrate various options for visualising and picking entities inside ANSYS Meshing
More specific controls added for Annotations.

Key highlight:

• If you turn off “Body Scoping Annotations” the purple highlighting of bodies when applying Inflation, Sweep, MultiZone, Etc. will not occur.

• The face annotations would still be visible unless you turn off “View Annotations”

• Example in next slide
We select the body to scope inflation to before the faces within.

With Body Scoping Annotations (BSA) ON we cannot grab faces inside easily.

With BSA OFF we can see inside to apply inflation to the faces more easily.
Viewing Surface Mesh

- Annotation preference exists to plot elements attached to NS
- When you select NS in the tree the mesh is shown
- Allows user to hide faces and plot surface mesh only to view
Hide/Show options on Named Selections

- What used to be Hide/Show has become Hide/Show Bodies in Group
- New Hide Face(s)/Show Hidden Faces option available when NS contains faces or bodies
  - Linked to “Visible” toggle in NS
Named Selections to Assist Meshing

- Sometimes we wish to create NS purely for mesh settings (sizing, inflation etc)
- Do not want to see these in solver!
- To do this we simply set the option “Send to Solver” to No and the NS is not passed into the solver
View Edge Biasing

- We cannot flip biasing direction (until R15) but we can view the “hardwired” biasing direction in the graphics window using arrows to pre-empt which edges go into which edge sizing control.

Switch on Arrow Visibility

Edge direction is shown in graphics to indicate biasing direction for edge sizings.
Reverse Biasing @ R15

Biasing points the wrong way for this edge

Set “Reverse bias” on this edge to correct orientation
Colour by NS/Sizing

- New “Random Colors” option in R14.5
- Depending on selection of Mesh Settings or Named Selections in tree we will see colour of boundaries change in the window and a legend to help identify them.
Problem statement: *Part Interfaces and Faults*

Do you struggle to get conformal mesh between parts?

Does this limit the mesh type you prefer, or make geometry editing or mesh generation more of a struggle than you would like?

Do you struggle with faults in the geometry that make flow volume extraction for otherwise clean geometry difficult?

The following discussion will demonstrate various options for dealing with mesh interfaces, and faults to improve your workflow and efficiency.
Conformal or Non-Conformal Meshing?

Conformal meshing desirable for:
- Fluid domains – continuous connected mesh most efficient
- Structural applications where contact elements undesirable

However there is a trade-off:

Conformal mesh:
- Solution time is less, Meshing time is more
- Constraints (size function, hex meshing, etc) propagate to neighboring bodies, increasing complexity for meshing

Non-Conformal mesh:
- Requires proper handling of contact regions
- Meshing is significantly easier
Conformal or Non-Conformal Meshing?

Both options have merit – Use Appropriately!

Tips: Use Share Topology options to help:

Select bodies and

- Automatic: Shared Faces
- Imprint: Duplicate, but exact faces
- None: Duplicate Faces

Use Operation and Color Edges to visualize.

The magenta edges will be meshed conformally with other bodies.

Here, the cylindrical body will be meshed separately, but the imprints from adjacent pipes create additional meshing constraints.

Here, the cylindrical body will be meshed separately, the lack of imprints makes meshing much easier.
Problem statement: *Failure to Mesh*

Is your geometry complex and meshing failures are not informative enough to diagnose the problems?

ANSYS developers are working hard to improve matters and as well as improving robustness in each release, diagnostic options are being made available.
Robustness – Failure Diagnostics

- “Show All failed” improved in 14.5
  - If Meshing fails all failed regions are given back to user so that user can fix all regions prior to remeshing
  - Helps indicate if just a few problems or more significant

Often user can add 1 layer of attached faces and VT group, re-mesh, Problem solved!